Welcome, Guest. Please login or register.

December 05, 2021, 08:29:39 AM

Login with username, password and session length

New Members

New Members

You should get an activation email when you join.  If not, please use the Contact option.
Members
Stats
  • Total Posts: 61349
  • Total Topics: 13636
  • Online Today: 43
  • Online Ever: 164
  • (August 20, 2021, 01:02:40 AM)
Users Online

Latest Post

Latest File

Author Topic: Trio R-2000 issue  (Read 743 times)

0 Members and 1 Guest are viewing this topic.

Offline acw6535

  • New Member
  • *
  • Posts: 9
Trio R-2000 issue
« on: April 17, 2021, 03:14:07 PM »
Hi
I`ve bought a Trio R-2000 HF receiver off ebay...set powers up ok,but it`s been fitted with the VC-10 VHF converter.
I`ve disconnected the VHF converter cable from the main set,but I`m still not able to tune the radio beyond the VHF band(118-174mhz).When I disconnected the VHF converter cable,there`s an E lit up in the box where the memory is displayed.

Anyone got one of these sets?
I don`t want to yank the VHF converter out without knowing I won`t be damaging the set

Thanks in advance
Allen

Offline mhm

  • Top Poster
  • *****
  • Posts: 2589
  • Age : As old as my hair and not as old as my teeth
    • Airradiouk
Mike
You can die of the cure before you die of the illness

Offline acw6535

  • New Member
  • *
  • Posts: 9
Re: Trio R-2000 issue
« Reply #2 on: April 18, 2021, 10:08:46 PM »
Thanks...for some reason,it`s now allowing me to tune the other frequencies.Maybe it`s an itermittent fault.It could probably do with a service,I think.There`s a radio repair shop in London-I`ll ask them to take a look at it.

Regards
Allen