New Members

New Members

You should get an activation email when you join.  If not, please use the Contact option.
Welcome, Guest. Please login or register.

April 11, 2021, 08:04:19 AM

Login with username, password and session length
Members
Stats
  • Total Posts: 53737
  • Total Topics: 13016
  • Online Today: 39
  • Online Ever: 97
  • (March 21, 2021, 08:40:17 AM)
Users Online
Users: 6
Guests: 29
Total: 35

Donations

Donations help with annual costs and keep Radarspotting free of advertising. Thank you.

Latest Post

Latest File

Silhouettes, Profiles and Operator Logos

If you're looking for a bulk download, we have over 66,000 aircraft silhouettes, profiles and operator logos available in bmp file format, 85x20 pixels. You can find all the Zip files here.  

For help installing these files, there's a free Guide here

Some of the Latest Additions:









Author Topic: ModesMixer2 Problem  (Read 1818 times)

0 Members and 1 Guest are viewing this topic.

Offline Quagmire

  • New Member
  • *
  • Posts: 3
ModesMixer2 Problem
« on: August 08, 2015, 10:30:46 PM »
Hi

I'm trying to get ModesMixer2 on my Pi2 - I got modesmixer2_rpi2_20150715.tgz file, unzipped it and ran this command
./modes2mixer $ ./modesmixer2 --inConnect 192.168.2.253:30005 --inServer 192.168.2.253:30004 --outServer msg:30053

and then got this error
2015-08-08 22:25:38.095  INFO     ModeSMixer2 v.20150715
terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::system::system_error> >'
  what():  bind: Address already in use

I've tried various --outServer combinations and port numbers but still the same message.

Can anyone help please.

Thanks

Offline dfroula

  • Member
  • **
  • Posts: 21
Re: ModesMixer2 Problem
« Reply #1 on: August 09, 2015, 08:21:49 PM »
It looks like one of the ports is already being used by the Pi. Try rebooting the Pi to clear any stuck port bindings on localhost?

Don

Offline evertonma

  • New Member
  • *
  • Posts: 10
Re: ModesMixer2 Problem
« Reply #2 on: September 30, 2015, 10:40:52 PM »
Hi!

I have exactly the same problem.

My hardware setup is a RPI2, ModeS Beast via USB and a RTL dongle used for straming to Liveatc.net.

Everytime when I reboot the RPI with both ModeS Beast and the RTL dongle, the Modesmixer2 shows this message error.

Can anyone help me please?