Welcome, Guest. Please login or register.

November 27, 2021, 07:40:10 AM

Login with username, password and session length

New Members

New Members

You should get an activation email when you join.  If not, please use the Contact option.
Members
Stats
  • Total Posts: 61006
  • Total Topics: 13632
  • Online Today: 63
  • Online Ever: 164
  • (August 20, 2021, 01:02:40 AM)
Users Online
Users: 6
Guests: 38
Total: 44

Latest Post

Latest File

Author Topic: acarsdeco2 on Win 10  (Read 4005 times)

0 Members and 1 Guest are viewing this topic.

junglejet

  • Guest
acarsdeco2 on Win 10
« on: September 12, 2016, 04:52:14 PM »
I have moved an acarsdeco2 folder to a new Win 10 MiniPC (Zotac PI320).

When I start acarsdeco with a USB R820T dongle I get

AcarSDeco2 v.20150718
Using device:  0 already in use
libusb_open error -12
Error: sdr_open(): Bad file descriptor

In the device manager there is a driver activated as a RTL2832 audio/video device. I have deactivated and deinstalled and renamed the driver files (3 files) and rebooted, but still the same message appears and the entry in the device manager is still visible, albeit without driver files.

I issued a --device-list command, but the response is empty.

I was under the impression that drivers are not required for the later acarsdeco2 versions, but something doesn't work here. Can anybody help?

Andy



Offline acarslogger

  • Member
  • ***
  • Posts: 84
Re: acarsdeco2 on Win 10
« Reply #1 on: September 13, 2016, 12:24:49 PM »
Hi Andy,

Sorry I can't help with a solution, but I also have exactly the same problem on my W10 machine.

Hopefully someone / Sergsero will assist with a solution.

Stuart

Offline Keef

  • Member
  • ****
  • Posts: 350
Re: acarsdeco2 on Win 10
« Reply #2 on: September 20, 2016, 10:59:47 AM »
I tried and got exactly the same error, however re-installing the zadig driver has fixed it for me.

I downloaded the driver from http://zadig.akeo.ie/ and followed the instruction here http://www.rtl-sdr.com/getting-the-rtl-sdr-to-work-on-windows-10/.


Might be worth a go.

Cheers,

Keef.

Offline acarslogger

  • Member
  • ***
  • Posts: 84
Re: acarsdeco2 on Win 10
« Reply #3 on: September 22, 2016, 01:18:49 PM »
Thanks for the information.
I'll give it a go when I return home to my W10 PC.

Thanks
Stuart

Offline acarslogger

  • Member
  • ***
  • Posts: 84
Re: acarsdeco2 on Win 10
« Reply #4 on: September 27, 2016, 07:08:14 PM »
Hi Keef,

The zadig solution worked. Up and running with AcarsDeco2 on Windows 10.

Thanks
Stuart

Offline Keef

  • Member
  • ****
  • Posts: 350
Re: acarsdeco2 on Win 10
« Reply #5 on: September 27, 2016, 11:46:14 PM »
Good to hear you're up and running again  :)

Cheers,

Keef.

Offline Keef

  • Member
  • ****
  • Posts: 350
Re: acarsdeco2 on Win 10
« Reply #6 on: May 01, 2018, 08:28:13 PM »
I know this is an old topic but it might be relevant again with the Windows 10 April Update landing on machines now.

I've just updated my PC and I had to go through this process again...

Cheers,

Keef.

Offline acarslogger

  • Member
  • ***
  • Posts: 84
Re: acarsdeco2 on Win 10
« Reply #7 on: May 16, 2018, 12:46:33 PM »
Hi Keef,

W10 April update arrived here and sure enough acarsdeco2 stopped working. Updated with zadig and now OK.

Thanks for the info.

Stuart
p.s. slightly off-topic but the W10 update also
-- corrupted my Virtual Audio Cables I used between SDRSharp and MultiPSK (for VDL2 and acars decoding). Had to un-install, re-install and reconfigure.
-- PuTTY (used to connect W10 PC to my Raspberry Pis) not working. I can use the W10 SSH. More Googling required.
-- my Network Locations that had been configured to access log file directories on the Raspberry Pi not working.
-- appears to have turned off File History
I wonder what other 'enhancements' I'll find in the new W10.
No response required, although I will raise another topic(s) if required -- just venting my frustration!